iznaur2002
12.01.2022 17:29

Напишите программу получения следующего узора для исполнителя Робот


Напишите программу получения следующего узора для исполнителя Робот

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Soniadesor
21.11.2020 06:35

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

0,0(0 оценок)
Ответ:
Alyona2022
26.08.2021 04:00

Вводятся координаты (x;y) точки и радиус круга (r). Определить принадлежит ли данная точка кругу, если его центр находится в начале координат.

Будем считать, что точка принадлежит кругу, если находится внутри его или на его окружности.

Из любой точки координатной плоскости можно провести отрезок к началу координат. Если длина этого отрезка больше радиуса круга, то точка лежит за пределами круга и, следовательно, не принадлежит ему. Если же отрезок, соединяющий точку и начало координат, меньше радиуса круга с центром в начале координат или равен ему, то точка будет принадлежать кругу.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота