Sasha34634
17.01.2020 14:20

Составить программу на языке паскаль для нахождения максимального элемента в массиве из 7 элементов(целых двухзначный чисел) заданного случайным образом

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kazhizhanov
01.10.2020 06:16


Program nechaeva97;
uses crt;
const n=7;
var
  i,t,max:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  max:=random(90)+10;
  write (max:5);
  for i:=2 to n do
    begin
      t:=random(90)+10;
      write (t:5);
      if max<t then max:=t;
    end;
  writeln();
  writeln('Максимальный элемент массива равен= ',max);
end.

0,0(0 оценок)
Ответ:
davideblan33
01.10.2020 06:16

uses crt;
var a:array [1..100] of integer;
max,i,n:integer;
begin
  randomize;
  for i:=1 to 7 do
  begin
    a[i]:=random(90)+10;
    write(a[i],' ');
  end;
  writeln;
  max:=a[1];
  for i:=1 to n do
    if a[i]>max then max:=a[i];
  write('max=',max);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота