nikemaxair55780
11.05.2022 16:35

Нужно написать программу, которая выводит таблицу степеней двойки (от нулевой до десятой).

На языке php

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Foxer20024
25.12.2022 19:37
Var
    a: array [,] of integer;

begin
    var n := ReadlnInteger('n = ');
    var m := ReadlnInteger('m = ');
    var rand := ReadlnInteger('Для ручного ввода нажмите 0');
    
    if rand = 0 then begin
        a := new integer[m, n];
        for var i := 0 to m-1 do
            for var j := 0 to n-1 do
                a[i, j] := ReadlnInteger('a[' + i + ',' + j + '] = ');
    end
    else a := MatrixRandom(m, n, 1, 100);
    Println(a);
    
    var b := ArrGen(n, x -> 1);
    for var i := 0 to m-1 do
        for var j := 0 to n-1 do
            if j mod 2 = 0 then
                b[j] := b[j] * a[i, j];
    
    b.Where((x, i)-> i mod 2 = 0).SortedDescending().Println();
end.
0,0(0 оценок)
Ответ:
allan1012
09.09.2021 01:08

#include <iostream>

using namespace std;

int main() {

// Variables

int number;

bool isPositive = false;

int numberCountDigits = 0;

// Input data

cout << "Input nubmer" << endl;

cin >> number;

// Create Solution

if (number > 999 || number < -999) {

 cout << "Incorrect number" << endl;

 return 0;

}

if (number >= 0) {

 isPositive = true;

}

while (number != 0) {

 numberCountDigits++;

 number /= 10;

}

// Output Solution

cout << "-- Information --" << endl;

isPositive ? cout << "Is Positive number" << endl : cout << "Is Negative number" << endl;

cout << "Digits count: " << numberCountDigits << endl;

return 0;

}


Пользователь вводит число от -999 до 999. Необходимо определить его знак и посчитать, сколько в нем
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота