Мусора12233334555
23.10.2021 16:29

Напишите программу для решение . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей , округля я значение скорости до целых чисел . необходимо определить минимальную зарегистрированную скорость автомобиля . если скорость хотя бы одного автомобиля была больше 80 км/ч , выведите yes иначе no . программа получает на вход число проехавших автомобилей n(1< =n< =30), затем указываются их скорости . значение скорости не может быть меньше 1 и больше 300 . программа должна сначала вывести минимальную скорость , затем yes или no .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tans83lsk
17.06.2020 08:24

uses crt;
var a:array[1..50] of real;
i,n,k:integer;
begin
  clrscr;
  write('chislo avto='); read(n);
  if (n>=1) and (n<=30) then

  begin
    writeln('skorosti:');
    for i:=1 to n do
    begin
      readln(a[i]);
      if a[i]>300 then write('error');
      if (a[i]>80) and (a[i]<=300) then k:=k+1;
    end;
    if k>0 then write('YES')
    else write('NO');
  end
  else write('error');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота