kokeoru1
06.03.2021 21:50

Написать алгоритм и составить программу для вычисления суммы квадратов первых n членов натурального ряда.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ismailismailov11
17.06.2020 08:03

Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.

 

program summa;

uses crt;

var N,a,s,i: integer;

begin

read(N); a:=0; s:=0;

for i:=1 to N do

begin

a:=a+1;

s:=s+(a*a);

end;

writeln(s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота