ivan01356
08.09.2021 07:14

Дано натуральные числа n. составить программу вычисления значения выражения:(1-2)*(1-3)*...(1-n)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
galuhlulia
04.04.2020 12:30
Если матрица подаётся построчно (вводить числа без [] разделённые пробелом)

# input

matrix = []

line = list(map(int, input().split()))

matrix.append(line)

for j in range(len(line) - 1):

   line = list(map(int, input().split()))

   matrix.append(line)

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))

Если одной строкой, уже массивом ([1,20,3,4],[2,5,5,5],[3,8,9,12],[8,9,10,11])

# input

matrix = input().split("],[")

matrix[0] = matrix[0][1:]

matrix[len(matrix) - 1] = matrix[len(matrix)-1][:len(matrix[len(matrix) - 1])-1]

newMatrix = []

for arr in matrix:

   line = list(map(int, arr.split(",")))

   newMatrix.append(line)

matrix = newMatrix

print(matrix)

# k + max

k = int(input("k: "))

maximum = matrix[0][0]

counter = 0

for arr in matrix:

   for num in arr:

       if num % k == 0:

           if maximum < num:

               maximum = num

           counter += 1

print("{0} чисел, кратных {1}".format(counter, k))

if maximum != 0:

   print("Максимальное число кратное {0} - {1}".format(k, maximum))

else:

   print("Нет чисел кратных {0}".format(k))


В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
В Python с двумерных массивов, решите задачу: Для целочисленной квадратной матрицы найти число элеме
0,0(0 оценок)
Ответ:
ivanBashak1
07.12.2021 19:27

так ну тут всё понятно

Объяснение:

Биография

После ядерной войны, которую в недалёком будущем развязал искусственный интеллект министерства обороны США «Скайнет», человечество было порабощено машинами и оказалось на грани уничтожения. Джон стал тем харизматичным лидером, который повёл уцелевших людей на борьбу. Под его руководством армия Сопротивления одержала полную победу к 2029 году. Скайнет, не имея возможности выиграть войну в настоящем, несколько раз посылал в роботов-убийц (терминаторов), чтобы предотвратить рождение Джона или убить его в юности.

Будущий отец Джона — солдат Сопротивления Кайл Риз родился в начале XXI века, вскоре после начала Войны[3] и, сам того не подозревая, служил под началом сына. Он вызвался добровольцем, чтобы быть отправленным в 1984 год для защиты от терминатора матери Джона — Сары Коннор. Сара и Риз влюбились друг в друга. Риз погиб, успев сообщить основную информацию о будущей войне.

Сара кардинально изменила свою жизнь, направив все силы на подготовку сына к его судьбе. Она уехала из США в Мексику и затем оказалась в Никарагуа, где обучилась военному делу, научилась обращаться с оружием. Со слов Джона, Сара была готова вступить в связь с каждым, кто мог научить Джона основам военного дела и сделать из мальчика будущего полководца. В начале 1990-х годов Сара и Джон вернулись в Лос-Анджелес. Сара предприняла неудачную попытку взрыва компании «Кибердайн Системс», и была арестована властями. Её посчитали сумасшедшей, и Джон вынужден был поверить, что её рассказы о будущем были плодом больного воображения.

Джону были назначены опекуны — Джанелл и Тодд Войты. Отношения с приёмными родителями у него не сложились: он рос хулиганом и имел проблемы с законом. К этому времени у Джона уже сформировался характер независимого волевого человека. Так продолжалось до тех пор, пока в возрасте 10 лет в 1994/1995 Джон не встретил двух терминаторов, которые вновь прибыли из будущего: один чтобы убить его, другой Совместными усилиями Сара, терминатор T-800 и Джон взорвали «Кибердайн системс» и уничтожили все следы пребывания терминаторов в настоящем, исключив тем самым появление Скайнет. При этом Джон был вынужден со слезами уничтожить и Т-800, который ему по факту заменил отца.

В альтернативном финале расширенной версии «Терминатора 2», Джон Коннор показан в мирном варианте будущего, спустя 34 года, после событий второй части. У него родилась дочь. В книге Р. Фрейкса, написанной по сценарию фильма, сказано, что Джон стал сенатором и добился принятия важных социальных законов.

Однако в Терминаторе 3 действие пошло иначе: разрушение «Кибердайн Системс» лишь отсрочило создание людьми системы «Скайнет», и из уже изменённого будущего, новый Скайнет высылает Терминатора «T-X» для самой себе на начальном этапе «освобождения от человечества». Также в фильме упомянуто, что в 2032 году Джон будет убит терминатором модели «T-850», который затем будет перепрограммирован и послан в его женой Кейт Брустер[en] для защиты. У Кейт и Джона будут дети, которые тоже сыграют важную роль в Сопротивлении, а сама Кейт, по словам Т Джону на начальном этапе войны организовать Штаб Сопротивления, пользуясь контактами в Армии США, будучи дочерью генерала Роберта Брустера, чьё ведомство и создало Скайнет.

Джон Коннор в фильме показан непосредственно перед началом ядерной войны в 2004 году. Его мать умерла от лейкемии через некоторое время после битвы со вторым терминатором. Судный день не наступил, и Джон предстаёт подавленным и разочарованным человеком, растерявшим свои волевые качества. Он не имеет постоянного места жительства и перебивается случайными заработками. Его вечно мучают кошмары о Судном дне и пришествии терминаторов.

Джон попадает в мотоаварию и вламывается в ветеринарную клинику, чтобы добыть лекарства. Там он встречает бывшую одноклассницу — теперь ветеринара Кейт Брустер, с которой он начал встречаться незадолго до знакомства с Т-800. Узнав, что Судный день был лишь отсрочен, Джон вместе с Кейт и Терминатором решает уничтожить сам Скайнет ради предотвращения войны, как в раз. Попытка терпит крах, и Терминатор доставляет Джона и Кейт в законсервированное ядерное убежище, где они становятся свидетелями ядерного катаклизма. Джон слышит сообщения уцелевших людей и выходит в радиоэфир, где объявляет себя лидером будущего Сопротивления.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота