Tto2036
20.08.2020 05:14

Не могли бы вы с информатикой? (Python 3.8.x) Среднее арифметическое N чисел X1..XN определяется так:

avg(X) = ( X1 + X2 + ... + XN ) / N

Арифметическая прогрессия - это последовательность чисел X1, X2, X3... таких, что разность между любыми двумя соседними числами постоянна и равна числу d, которое называется шагом арифметической прогрессии. Напишите программу вычисляющую среднее арифметическое avg(X) первых N чисел арифметической прогрессии, заданной своим первым элементом X1 и шагом d.

Input

В единственной строке заданы три целых числа 1<=N<=109, -1000<=X1<=1000 и -1000<=d<=1000.

Output

Ваша программа должна вывести единственную строку содержащую значение avg(X) арифметической прогрессии X1..XN с заданными X1 и d. Входные данные таковы, что avg(X) будет целым числом в диапазоне [-10⁹; 10⁹].

Входные данные :

5 3 7

Выходные данные :

17

В данном примере нужно посчитать среднее арифметическое чисел : 3, 10, 17, 24 и 31, которое равно 85 / 5 = 17.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
leonid90
06.07.2020 19:35
Program Turashova_Anna;

Const  V: String = '01';  
Function DecToN(A: Longint; D: Byte) : String; 
Begin  If A > D - 1  
then DecToN := DecToN(A div D, D) + V[(A mod D) + 1] 
else DecToN := V [A + 1]; 
end;    

Function NToDec(A: String; D: Byte): Longint;   
Begin   
If Length(a) > 0    
then NToDec := Pos(A [Length(A)], V) - 1 + D * NToDec(Copy (A, 1, Length(A) - 1), D)   
else NToDec := 0;   
end;

Var F: String;     
Begin     
Write('Входной файл Input.txt: '); Readln(F); 
If NToDec(F,2)      
mod 7 = 0      
then Writeln('Выходной файл Output.txt: 0',DecToN(NToDec(F,2) div 7,2))      
else Writeln('Выходной файл Output.txt: 0');     
end.
0,0(0 оценок)
Ответ:
dehezy
17.02.2023 03:33

Строка вводится с клавиатуры(максимум 99 символов). Первое слово должно быть с маленькой буквы или первая и последняя буквы этого слова не должны совпадать(иначе такое слово как Test не засчитается). Также будет засчитываться одна буква(abc d efg, буква d подходит, так как она и первая и последняя)

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strtok;
using std::strlen;

int main()
{
char a[100], *ptr;

cout << "Enter the string:" << endl;
cin.getline(a, 100);

cout << endl;

ptr = strtok(a, "., ");
while(ptr)
{
if(*ptr == *(ptr + strlen(ptr) - 1))
{
cout << ptr << ' ';
}

ptr = strtok(NULL, "., ");
}

cout << endl;

return 0;
}


Дана строка. найти в ней те слова, которые начинаются и оканчиваются одной и той же буквой. язык си+
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота