OlyaKasyanenko28
02.06.2020 17:43

Напишите программу, которая запрашивает у пользователя число. Если число больше нуля, то вывести на экран сообщение «Тепло». Если введенное число меньше нуля, то вывести сообщение на экран «Холодно»
на языке python)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
НеПøтêpяHHåя
04.08.2021 20:50
A,b,c - стороны прямоугольного треугольника;
d - радиус описанной окружности около прям. треуг.
e - длинна окружности описанной около прямоуг. треугольника;

var a,b,c,d,e:Real;
begin
writeln ('Введите (через пробел) 2 катета прямоугольного треугольника: ');
readln (a,b); //вводим 2 катета
c:=SQRT((a*a)+(b*b)); //находим 3 сторону (гипотенузу)
d:=0.5*c; //радиус описанной окружности около прям. треуг
e:=2*3.14*d; //теперь находим длину окружности описанной около прям. треуг.
writeln ('Длина окружности описанной около прямоугольного треугольника = ',e);
end.

P.S. то что после // - это комментарий (в паскале он будет выделен другим цветом), это для того что бы было понятно, что сейчас делаем, если комментарии не нужны - их можно удалить, на правильность работы программы это никак не повлияет
0,0(0 оценок)
Ответ:
ГлебGleb39
14.05.2021 21:01

Вопрос скорее будет звучать "как много могли съесть толстяки?".

#include <iostream>

using namespace std;

int main() {

int multiplier = 1;

float weightCake = 0;

float t1(0), t2(0), t3(0);

float t1Cakes(0), t2Cakes(0), t3Cakes(0);

cout << "Weight of cake, fat people 1-3: ";

cin >> weightCake; cin >> t1; cin >> t2; cin >> t3;

while(1) {

t1Cakes = multiplier * weightCake * 1;

if(t1Cakes > t1/2) {

    cout << multiplier - 1;

    break;

}

t2Cakes = multiplier * weightCake * 2;

   if(t2Cakes > t2/2) {

 cout << multiplier - 1;

    break;

   }

t3Cakes = multiplier * weightCake * 4;

   if(t3Cakes > t3/2) {

    cout << multiplier - 1;

    break;

   }

++multiplier;

}  

}


Нужно решить задачку на C++ Трем толстякам подали на десерт кремовые пирожные. Масса одного пирожног
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота