lebedevamilp00sr9
07.06.2022 19:14

Составить программу, вычисляющую систему уравнения: x = { 0, x^3, если x _< 0; если x >0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rhxtdf
25.03.2021 22:28

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   // problem 1 //

   ll x;

   cin >> x;

   if(x > 0)

       x *= 5;

   else

       x -= 10;

   cout << x << "\n\n";

   // problem 1 //

   // problem 2 //

   ll a[3];

   for(ll i = 0; i < 3; i++)

       cin >> a[i];

   sort(a,a+3);

   cout << a[0] + a[1] << "\n\n";

   // problem 2 //

   // problem 3 //

   ll y;

   cin >> y;

   if(y > 0)

       y++;

   else

       y -= 2;

   cout << y << "\n\n";

   // problem 3 //

   // problem 4 //

   ll b[3];

   for(ll i = 0; i < 3; i++)

       cin >> b[i];

   sort(b,b+3);

   cout << b[2] + b[1];

   //problem 4 //

}

0,0(0 оценок)
Ответ:
lub3
25.03.2021 22:28
1.
алг
нач цел X
ввод X
если X>0 то 
X:=X+1
все
вывод X 
кон

2.
алг
нач цел X
ввод X
если X>0 то
X:=X+1
иначе
X:=X-2
все
вывод X 
кон

3.
алг
нач цел X
ввод X
 если X>0 то
  X:=X+1
 все
 если X<0 то
  X:=X-2
 все
 если X=0 то
  X:=10
 все
вывод X
кон

4.
алг
нач цел X,Y,Z,N
ввод X,Y,Z
N:=0
если X>0 то
N:=N+1
все
если Y>0 то
N:=N+1
все
если Z>0 то
N:=N+1
все
вывод N
кон

5.
алг
нач цел X,Y,Z,N,K
ввод X,Y,Z
N:=0
K:=0
если X>0 то
N:=N+1
иначе
K:=K+1
все
если Y>0 то
N:=N+1
иначе
K:=K+1
все
если Z>0 то
N:=N+1
иначе
K:=K+1
все
вывод N,K
кон

Самые наиболее простые варианты выбрал думаю в самый раз
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота