Девочка134
21.09.2022 03:34

1.Напишите программу,которая получает с клавиатуры натуральное число и определяет,сколько Цифр в его десятичной записи. (пайтен)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
125DVV
13.07.2020 13:59
#include <cstdlib>#include <iostream> using namespace std; void MassNullEllement(int *Mass){     int KolEl = 0 ;     for(int a=0;a<5;a++){        if(Mass[a]!=0){KolEl++;}        }     cout<<"amount element not equal zero = "<<KolEl<<"\n";    } int main(int argc, char *argv[]){    int Massiv[5];    for(int b=0;b<5;b++){            cout<<"Enter "<<b<<" element - ";
cin>>Massiv[b];           }   MassNullEllement(Massiv);    system("PAUSE");    return EXIT_SUCCESS;}
0,0(0 оценок)
Ответ:
Рита0Венес
17.12.2020 04:17
Var
    a, b, c, p: real;
    a1, b1, c1: real;
    a2, b2, c2: real;

function SideLength(a1, a2, b1, b2: real): real;
begin
    SideLength := sqrt(sqr(a1 - b1) + sqr(a2 - b2));
end;

begin
    writeln('1.Найти сумму трех чисел');
    readln(a, b, c);
    writeln(a + b + c);
    
    writeln('2.Катеты прямоугольного треугольника известны.Найти гипотенузу.');
    readln(a, b);
    writeln(sqrt(a * a + b * b));
    
    writeln('3.Найти среднеарифметическое двух чисел.');
    readln(a, b);
    writeln((a + b) / 2);
    
    writeln('4.Найти длину окружности,если известна площадь круга.');
    readln(a);
    writeln(sqrt(a / pi) * 2 * pi);
    
    writeln('5.Какой процент составляет число а от числа b.');
    readln(a, b);
    writeln(a / b * 100);
    
    writeln('6.Найдите площадь треугольника с формулы Герона.');
    readln(a, b, c);
    p := (a + b + c) / 2;
    writeln(sqrt((p - a) * (p - b) * (p - c) * p));
    
    writeln('7.Найдите площадь кольца,если его толщина I см,диаметр внутри круга d см.');
    readln(a, b);
    c := a + b;
    writeln(pi * (c * c - b * b));
    
    writeln('8.Вычислите площадь треугольника заданного координатами вершин.');
    readln(a1, a2, b1, b2, c1, c2);
    writeln(((a1 - c1) * (b2 - c2) - (a2 - c2) * (b1 - c1)) / 2);
    
    writeln('9.Вычислить длинны сторон треугольника по заданным координатам его вершин.');
    a := SideLength(a1, a2, b1, b2);
    b := SideLength(c1, c2, b1, b2);
    c := SideLength(a1, a2, c1, c2);
    writeln(a, ' ', b, ' ', c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота