1337banana228
05.07.2021 15:00

4. Напишите программу, которая выведет на экран все
натуральные числа от 1 до 1000, кратные 3.​


4. Напишите программу, которая выведет на экран всенатуральные числа от 1 до 1000, кратные 3.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hrndo
06.02.2022 13:47
1) Независимо от условия будет выполнен оператор присваивания.
a:=b
2) Условие ложное, значит будет выполнен оператор после else
write('b')
3) Условие истинное, значит будет выполнен оператор после then
write('a')
4) Функции операторов присваивания одинаковы, значит не зависят от условия (a + b - 14 = b - 14 + a)
a := a + b - 14
5) Оператор a := a практически ничего не изменяет, значит можно избавится от него
if a<b then a:=b
6) То же самое, что и в пункте 5, только нужно поменять истину на ложь
if not(a>b) then a:=b
7) Остаток деления на 2 не может быть равен трем, значит условие всегда ложно. Else нет, значит условный оператор можно смело откинуть
8) Остаток от деления на может быть равен или 0 или 1, значит в любом случае условие истинно. Первый условный оператор можно смело откинуть, но вложеннный остается!
if a<0 then a:=-a
9) Если a отрицательное, тогда b = a, то есть тоже отрицательно. Если a неотрицательное, тогда b = -a, то есть b отрицательное. Можно записать как модуль числа a, умноженный на -1
b := -abs(a)
0,0(0 оценок)
Ответ:
Ashmalikova
02.05.2020 19:16
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота