pershikovanata
13.03.2020 05:16

Составить программу, которая считывает элементы двумерного массива и меняет отрицательные элементы на -1, положительные на 1. полученную матрицу выводит на экран. (паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nastyacat200809
09.03.2020 21:27

графы в информатике являются способом определения отношений в совокупности элементов. это основные объекты изучения  теории графов.

базовые определения

из чего состоит граф в информатике? он включает множество объектов, называемых вершинами или узлами, некоторые пары которых связаны т. н. ребрами. например, граф на рисунке (а) состоит из четырех узлов, обозначенных а, в, с, и d, из которых b соединен с каждой из трех других вершин ребрами, а c и d также соединены. два узла являются соседними, если они соединены ребром. на рисунке показан типичный способ того, как строить графы по информатике. круги представляют вершины, а линии, соединяющие каждую их пару, являются ребрами.

какой граф называется неориентированным в информатике? у него отношения между двумя концами ребра являются симметричными. ребро просто соединяет их друг с другом. во многих случаях, однако, необходимо выразить асимметричные отношения – например, то, что a указывает на b, но не наоборот. этой цели служит определение графа в информатике, по-прежнему состоящего из набора узлов вместе с набором ориентированных ребер. каждое ориентированное ребро представляет собой связь между вершинами, направление которой имеет значение. направленные графы изображают так, как показано на рисунке (b), ребра их представлены стрелками. когда требуется подчеркнуть, что граф ненаправленный, его называют неориентированным.

0,0(0 оценок)
Ответ:
OrAcUl
12.05.2021 17:06

from itertools import product

i = open('input.txt', 'r')

o = open('output.txt', 'w+')

l = int(i.

alpha = "245"

d = []

for s in product(alpha, repeat=l):

    d.append([" ".join(

for q in d[1: ]:

    s = " ".join(q)

    if int(s.count('2')) > 2:

        continue

    o.write(" ".join(q) + '\n')

i.close()

o.close()

код к : «перевод кода с питона на паскаль»

var

n,c,i,ost,b,t,d: integer;

a,k: string;

begin

readln(n);

c: =1;

for i: =1 to n do

c: =c*3;

c: =c-1;

for i: =1 to c do

begin

k: ='';

b: =i;

t: =0;

while b> 0 do

begin

ost: =b mod 3;

if ost=0 then inc(t);

d: =(-sqr(ost)+5*ost+4)div 2;

str(d,a);

k: =a+k;

b: =b div 3;

end;

while length(k)do

begin

k: ='2'+k;

inc(t);

end;

if t< =2 then writeln(k);

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота