сказкамоямечта
14.07.2021 22:36

С++ Дан массив из 10 элементов. Вывести на экран девятый элемент. Точность чисел - 2 знака после запятой.
Формат входных данных
Вводятся 10 вещественных числел ai, не превосходящих 1000 по абсолютной величине и имеющих не более двух знаков после запятой, — элементы массива.
Формат выходных данных
Вывести на экран девятый элемент.
входные данные
1.01 2.02 3.03 4.04 5.05 6.06 7.07 8.08 9.09 10.10
выходные данные
9.09

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Yarik200825
24.09.2021 01:36

1)

Program Pr1;
uses crt;
var stroka:string;
i,k:integer;
Begin
clrscr;
writeln('Vvedite chislo');
readln(stroka);
k:=0;
for i:=length(stroka) downto 1 do if stroka[i]='3' then k:=i;
writeln(k);
end.

2)

Program Pr2;
uses crt;
var stroka:string;
i,k,x,y:integer;
Begin
clrscr;
readln(stroka);
y:=0;
for i:=length(stroka) downto (length(stroka)-1) do begin
val(stroka[i],k,x);
y:=y+k;
end;
writeln(y);
end.

 3)

Program Pr2;
uses crt;
var stroka:string;
i,y,k:integer;
mas:array[byte] of integer;
Begin
clrscr;
readln(stroka);
for i:=1 to length(stroka) do begin
val(stroka[i],y,k);
mas[i]:=y;
end;
k:=0;
for i:=1 to length(stroka) do if mas[i]>k then k:=mas[i];
writeln(k);
end.

4)

Program Pr2;
uses crt;
var stroka,tmp:string;
Begin
clrscr;
readln(stroka); {1-oe predlojenie}
readln(tmp); {2-oe predlojenie}
delete(stroka,1,length(tmp));
stroka:=tmp+stroka;
writeln(stroka);
end.

5)

Program Pr2;
uses crt;
var mas:array[byte] of integer;
i,n,f:integer;
Begin
clrscr;
readln(n);
mas[1]:=1;
mas[2]:=1;
for i:=3 to n do mas[i]:=mas[i-1]+mas[i-2];
writeln(mas[n],' a'); {a}
readln;
for i:=1 to n do write(mas[i],' '); {á}
f:=0; {â}
readln;
for i:=1 to n do f:=f+mas[i];
if f mod 2=0 then writeln('TRUE')
else writeln('FALSE');
end.

0,0(0 оценок)
Ответ:
kote03012
12.11.2021 20:38

1.Дан фрагмент программы:

x:=52;

write ( 'ответ: ', х: 2,'км/ч');

После его выполнения на экран будет выведено:

2)ответ: 52км/ч

2.Укажите операторы вывода данных:

1)Write

4)Writeln

3.Целочисленным переменным a, b, c надо присвоить соответственно значения 10, 20 и 30. Какой оператор ввода соответствует входному потоку 30 20 10?

1)read (c, b, a)

4.Для ввода в оперативную память значений переменных используется оператор:

3)readln

5.Что будет выведено на экран после выполнения следующей программы:

begin

writeln (‘Hello, ’);

write (‘World!’)

end.

2)Hello,

World!

Вообще ошибку, потому что кавычки не правильные

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота