лиза4710
21.11.2021 13:53

Написать программу для нахождения наибольшей цифры целого положительногочисла. Длина числа до 9 цифр. (В программе Pascal). ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mariana20021
22.04.2023 05:19
Const Sz = 1000; var   a: array [1..Sz] of integer;  b: array [1..Sz] of integer;  c: array [1..Sz] of integer;  d: array [1..Sz] of integer;  M: integer;  N: integer;  i: integer;  k: integer;begin  read(M);  readln(N);  for i:=1 to N do begin    read(a[i]);    readln(b[i]);    if (a[i]<>0) then c[i]:=1 else c[i]:=0;    end;  for i:=1 to N do begin  if(c[i]<>0) then begin  for k:=1 to i do begin  if(d[k]=0) then d[i]:=1;  if (c[k]=i) then d[k]:=0;   end;   writeln(d[i])  end;end;end.
0,0(0 оценок)
Ответ:
TOLKACHEV11
22.04.2023 05:19
Const Sz = 1000; var   a: array [1..Sz] of integer;  b: array [1..Sz] of integer;  c: array [1..Sz] of integer;  d: array [1..Sz] of integer;  M: integer;  N: integer;  i: integer;  k: integer;begin  read(M);  readln(N);  for i:=1 to N do begin    read(a[i]);    readln(b[i]);    if (a[i]<>0) then c[i]:=1 else c[i]:=0;    end;  for i:=1 to N do begin  if(c[i]<>0) then begin  for k:=1 to i do begin  if(d[k]=0) then d[i]:=1;  if (c[k]=i) then d[k]:=0;   end;   writeln(d[i])  end;end;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота