Retrostyle
17.07.2020 22:54

С ИНФОРМАТИКОЙ Составить программу нахождение минимального элемента в массиве из 15
вещественных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ketkovalchuk
15.03.2021 04:35

var a,b:integer;        - говорит программе, что будут использовать целые числа в переменных                        

                                         А и В 

begin                            - начало программы

a:=0;                             - а = 0

b:=2364;                       - b = 2364;

while b>0 do begin      - Пока b > 0  делать

f b mod 10<5 then       - Если b разделить на 10 в остатке получится число меньше 5 тогда

a:=a+b mod 10;          - а = а + b разделить на 10 и найти остаток (этот остаток и прибавить

b:=b div 10;                 - b = b разделить на 10 и найти целую часть, на эту целую часть 

                                        заменить старое значение переменной b

end;                             - конец цикла

writeln(a);                     - напечатать А

end.                             - конец программы

 

Работает так:

1) a = 0

b = 2364

2364 > 0 да

2364 / 10 = 236 ост 4

4<5 да тогда а = 0 + 4 = 4

b = 2364 / 10 = 236  - находим только целую часть числа

 

2) проверяем снова условие

236 > 0  да

236 / 10 = 23 ост 6

6 < 5 нет - ничего не делаем ( а осталось равно 4)

b = 236 / 10 = 23  - находим только целую часть числа

 

3) проверяем снова условие

23 > 0 да

23 / 10 = 2 ост 3

3<5  да тогда а = 4 + 3 = 7

b = 23 / 10 = 2 -  находим только целую часть числа

 

4) проверяем снова условие

2 > 0 да

2/10 = 0 ост 2

2<5 да, тогда а = 7 + 2 = 9

b = 2 / 10 = 0  -  находим только целую часть числа

5) проверяем снова условие

0 > 0 нет

 

закончили цикл

 

Напечатать а = 9

конец алгоритма

 

Алгоритм считает сумму цифр в числе В, которые меньше 5

0,0(0 оценок)
Ответ:
дошикестдошик
21.09.2022 18:03

Есть две переменные а и б
Изначально а=0, б=2364

 

Пока б будет больше 0 он будет выполнять следующие действия:

если остаток от б/10 меньше нуля тогда к А прибавляется этот остаток.
 Б делим на 10 и повторяем

 

Вывод А

 

Сама задача вычисляет сумму цифр в числе которые меньше 5.
Дано Б = 2364.

Задача смотрит остаток от 2364 mod 10 = 4

4 меньше пяти соответственно в А=4

далее 2364/10=236

 

теперь 236 mod 10 = 6

6 больше пяти поэтому ниче не делаем

236 div 10 = 23

 

теперь 23 mod 10 = 3

3 меньше пяти соответственно А=А+3 = 4+3 = 7

23 див 10 = 2

 

теперь 2 mod 10 = 2

2 меньше 5 соответственно А=А+3 = 7+2 = 9

2 див 10 = 0

 

Так как Б=0 программа выходит из цикла и выводит А, т.е. число 9

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота