terteryanmarin
25.09.2021 09:26

Составить программу вычисления функции у=3х-2 для всех х от –N до N (N вводится с клавиатуры) с использованием цикла с предусловием (на Phyton)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
marilmermaidp08sv1
22.01.2021 06:26

// Програма1:

#include <iostream>

using namespace std;

const int n = 15;

int main() {

int i, count;

float B, A[n];

 

cout << "B=";

cin >> B;

for(i = 0; i < n; i++){

 cout << "A[" << i << "]="; cin >> A[i];

}

 

count = 0;

for(i = 0; i < n; i++)

 if (A[i] > B)

  count++;

cout << count << endl;

 

return 0;

}

// Програма2:

#include <iostream>

using namespace std;

const int n = 15;

int main() {

  int i, count;

  float B, A[n] = {3.05,-9,-5,22.5,12,-6.045,5,9,3,-5,4.1,8,1,0,15};

  cout << "B=";

  cin >> B;

  count = 0;

  for(i = 0; i < n; i++)

      if (*(A + i) > B)

          count++;

  cout << count << endl;

  return 0;

}

0,0(0 оценок)
Ответ:
123456qwe1234567
09.07.2020 22:35
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота