Войти
Регистрация
Спроси ai-bota
sasunaklukina
04.09.2022 20:59
Дан одномерный массив a(2n).сформировать двумерный массив
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
КсюшаГретт
09.10.2022 15:56
Запишите арифметические выражения на языке программирования python а) х*у-12/34+х с)х+у/а*а/х-у 10 в 4 степени А - 3(целых) 1/5...
tatleb
30.12.2022 03:58
Составить алгоритм нахождения суммы и количества положительных элементов массива A(40). НУЖНО БЛОК-СХЕМУ СОСТАВИТЬ...
MsMerenberg86
04.11.2020 22:45
Контрольная работа по теме основы алгоритмизации...
letochka111
21.04.2021 07:41
Даны натуральные числа a и b, обозначающие соответственно числитель и знаменатель дроби. сократите дробь, то есть найдите такие натуральные числа p и q, не имеющие общих натуральных...
Данек44
21.04.2021 07:41
Напишите программу , которая в последовательности натуральных чисел определяет сумму чисел ,кратных 4 и оканчивающихся на 6. программа получает на вход количество чисел в последовательности...
Mogolan
21.03.2023 00:28
Дано n чисел найдите минимальное из них. !...
suleymanovrusl
21.03.2023 00:28
Дано n чисел найдите минимальное из них...
ivanovmax
17.11.2021 17:34
ЗАДАЧА С++ Визначити кількість цифр у даній послідовності....
zzzzzzz03
30.09.2022 06:06
За 4 минуты 16 секунд были переданы 4 файла размером по 256 кбайт. чему равна скорость передачи данных через adcl-соединение? значение указать в кбит/с...
AlexSubbotin11
23.09.2022 12:15
Скорость передачи данных через adsl-соединение=128 кбит/с. за 1 минуту 4 секунды передали 2 одинаковых файла. определите объем одного файла в кбайтах...
Ответ:
marisa10
26.11.2021 09:33
[l,r,строка,номер]
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
0,0
(0 оценок)
Ответ:
vlada363
16.03.2020 21:38
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота