Анастасияя12345
13.02.2021 02:32

(надо составить программу либо на языке GNU C++ 5.4.0 либо на Pyton либо на Java JDK 1.8.0_171)
№1
Недавно Ваня и Даня играли в шахматы на перемене - и решили сделать из шахмат настоящую
головоломку. К счастью, это оказалось не так сложно, ведь у них в распоряжении оказалась не
просто доска 8 × 8, а доска n × m, а также n · m слонов.
Для начала (для будущего удобства) Ваня и Даня решили пронумеровать все клетки доски
змейкой, начиная с самой нижней клетки.
Как уже была сказано, у Вани и Дани в распоряжении есть очень много слонов, поэтому они и
будут «главными героями» их головоломки. Придуманная Ваней и Даней, головоломка заключается
в нахождение клетки с наибольшим значением magicchessp
, где magicchessp обозначает количество
итераций определенного алгоритма.
Сначала мы ставим слона в клетку с номером p, и пока у нас есть пустые клетки на поле, которые
бьются хоть одним слоном, мы будем выбирать из таких клеток минимальную по номеру – и ставить
туда слона. Количество итераций такого алгоритма и будет значением magicchessp
.
Теперь Даня и Ваня просят им с этой головоломкой, если известны n и m - размеры
доски. Но вам не требуется искать саму клетку с наибольшим magicchessp
, вам требуется найти
лишь максимальный magicchessp
.

№2
Сегодня на уроке зельеварения Ваня придумал для себя увлекательную игру. Сначала Ваня
ставит на числовой прямой три различных точки в целых координатах. После этого он может взять
одно из крайних чисел и переместить его в любую целую точку между двумя оставшимися, где
крайним мы называем минимальное или максимальное из чисел. Он повторяет это действие до тех
пор пока это возможно.
Например, если изначально выбрать точки {2, 4, 8}, после первого хода могут получится следующие комбинации чисел: {2, 3, 4}, {4, 5, 8}, {4, 6, 8}, {4, 7, 8}. В первом случае игра заканчивается
после первого же хода, в остальных случаях можно сделать еще хотя бы один ход.
Теперь Ване интересно, сколько ходов он может сделать для любой заданной тройки точек. К
сожалению Вани, зельеварение закончилось - и теперь он сам не успеет выяснить это ему!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
danialSANDY
04.04.2021 16:17
Код Pascal;

Var
   x,y,v,h,dx:real;
Begin
Write('y = ');ReadLn(y);
Write('v = ');ReadLn(v);
Write('h = ');ReadLn(h);
dx:=0.31;
x:=-4;
Repeat
WriteLn('f(',x,') = ',Exp(Sin(y)*Abs(x))-3*Sqrt(v-h));
x:=x+dx;
Until x > -1
End.

Пример работы программы:

y = 3
v = 4
h = 2
f(-4) = -2.4841075227142
f(-3.69) = -2.55937994576573
f(-3.38) = -2.63143040076643
f(-3.07) = -2.70039680114727
f(-2.76) = -2.76641115707942
f(-2.45) = -2.82959982815798
f(-2.14) = -2.89008376526975
f(-1.83) = -2.94797874210812
f(-1.52) = -3.00339557677815
f(-1.21) = -3.05644034391605
0,0(0 оценок)
Ответ:
Shaurma021
22.09.2021 14:05
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота