FREDYPAW
11.08.2022 08:20

Дан целочисленный линейный массив из 10 элементов. найдите наименьшее число k элементов, которое нужно исключить из последовательности a[1], a[2],…,a[10], чтобы осталась возрастающая последовательность.язык delphi или паскаль буду признателен

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yuliya226
21.07.2022 12:13

<!doctype html>

<html lang="ru">

<head>

 <meta charset="UTF-8">

 <meta name="viewport"

       content="width=device-width, user-scalable=no, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0">

 <meta http-equiv="X-UA-Compatible" content="ie=edge">

 <title>Пользователю</title>

 <style>

   .card {

     display: inline-block;

     background-color: black;

     min-height: 300px;

     min-width: 150px;

   }

 </style>

</head>

<body>

<div class="container">

 <div class="card"></div>

 <div class="card"></div>

 <div class="card"></div>

</div>

</body>

</html>

0,0(0 оценок)
Ответ:
veno1
25.04.2020 01:52

A = [75, 31, 80, 40, 48, 40]  # любой список

# Готовые решения для этих задач:

print(sum(A))  # Сумма

# Произведение

A = [35, 2, 82, 10, 44, 42]

import functools

import operator  # содержит все возможные операции

print(functools.reduce(  # reduce - применить операцию ко всем элементам списка поочерёдно

       operator.mul,  #  операция умножения

       A))

# Через цикл

# Сумма:

S = 0

for i in A: S += i  # Сложить все элементы A, результатом будет переменная S

print(S)

# Произведение:

M = 1  # Если будет 0, то всё выражение тоже будет 0

for i in A: M *= i


# Или

if 0 in A: M = 0

else:

   for i in A: M *= i

print(M)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота