topovyjpocan
26.07.2022 16:40

1.можно ли поменять элементы массива на их противоположные значения, не используя условный оператор (например, если положительное число то заменить его на отрицательные и наоборот)? 2.Как можно поменять местами два любых элемента массива?
3.Какие проекты из курса математики, физики и других предметов можно создать с использованием замены элементов массива на языке программирования Python?
4.Как вы думаете, можно ли автоматически загрузить массив числовыми элементами от 1-го до 20-ти по возрастанию без использования клавиатуры? Приведите свои обоснования.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sashaewr444
14.09.2020 04:14

Объяснение:

1.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 while (i<=n) do begin

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 end;

 writeln(count);

 readln;

end.

2.

var

 a:array[1..1000] of integer;

 i, n:integer;

 count:integer;

begin

 writeln('Input n = ');

 readln(n);

 for i:=1 to n do begin

   writeln('Input a[', i, '] = ');

   readln(a[i]);

 end;

 count:=0;

 i:=1;

 repeat

   if (((a[i] mod 3) = 0) and ((a[i] - (a[i] div 10)*10) = 2)) then count:=count + 1;

   i:=i+1;

 until (i > n);

 writeln(count);

 readln;

end.

0,0(0 оценок)
Ответ:
sona238
14.09.2020 04:14

Var

  size: integer;

  counter: integer;

  mas: array of integer;

   

Begin  

  Write('Введите количество чисел в последовательности: ');

  Readln(size);

   

  if (size > 0) then

  begin

     Writeln();

     SetLength(mas, size);

     

     for var i := 0 to size - 1 do

     begin

        Write('Введите ', i + 1, ' число: ');

        Readln(mas[i]);

         

        if ((mas[i] mod 3 = 0) and (mas[i] mod 10 = 2)) then

           counter := counter + 1;

     end;

     

     Writeln();

     Writeln('ответ: ', counter);

  end

   

  else

     Writeln('Количество чисел должно быть больше нуля!');

   

End.


Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, крат
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота