dashanovikova03
02.03.2021 02:20

Здравствуйте, кто разбирается в информатике Составьте программу, которая вводит с клавиатуры натуральное число n и выводит на экран значение суммы:

- 1/3 + 1/5 - 1/7 + ... + (-1)^n / 2n + 1

2) Составьте программу, которая вводит с клавиатуры натуральное число n и действительное число x, а затем выводит на экран значение суммы:

x1/1! + x2/2! + x3/3! +...+ xn/n!

(В Паскале, сделать с операции for )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mamrykovaksun
10.03.2021 22:12

Задача 1:

var i,n:integer;

sum:real;

begin

   sum:=0;

   write('Введите N: '); readln(n);

   for i:=1 to n do sum:=sum+exp(-1*ln(n))/(2*n+1);

   write(sum:0:3);

end.

Задача 2:

var i,n,x,k:integer;

sum:real;

begin

   sum:=0;

   k:=1;

   write('Введите N: '); readln(n);

   write('Введите X: '); readln(x);

   for i:=1 to n do begin

       k:=k*i;

       sum:=sum+x*i/k;

   end;

   write(sum:0:3);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота