элллллляяяяя555
09.09.2021 23:06

Написать программу «выделение цифр в записи числа» дано трехзначное число. определить, является ли сумма его цифр кратна 3 и 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nastya45t7
16.06.2020 14:46

var

a,s,n:integer;

begin

repeat 

write ('A =');readln(a);

until (a>=100) and (a<=999);

n:=a; 

while n div 10 <> 0 do begin

n:=a; 

s:=s+a mod 10;

a:=a div 10;

end;

if (s mod 3 = 0) or (s mod 5 = 0) then writeln ('Yes') else writeln ('No');

readln;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота