Aynur123455
12.04.2023 04:40

Си++ составить программу, печатающую все простые числа из диапазона [2, n] при целом n > 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gorki2005
01.10.2020 04:35


#include <iostream>
using namespace std;
int isSimple (int x)
{
int retVal = 1;
int i = 2;
while (i<=sqrt((double)x) && retVal==1)
{
if (x%i==0) retVal=0;
i++;

}
return retVal;
}

void main(){
int n(0);
cout<<"write n "; cin>>n;
if (n < 3)
cout<<"error";
else {
for (int i=2;i<=n;i++)
if (isSimple(i)) cout<<i<<" ";
}
cout<<endl;
system("pause");
}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота