Войти
Регистрация
Спроси ai-bota
KapitanNEMO
12.04.2020 10:07
Загрузи программу задание 2 в модуль ЕV3,запусти программу на работу и убедись в том,что программа выполняется.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Dimas1694
29.08.2022 16:30
Напишите программу на языке программирования (или составьте алгоритм). подсчитать количество простых чисел в одномерном массиве размером n, состоящем из целых чисел, полученных...
Skecher
08.10.2022 23:34
Для каких изображений подходит метод сжатия rle? (скажите )...
kovdalg
09.11.2020 22:40
Метерологическая станция ведет наблюдение за влажностью воздуха. результатом одного измерения является целое число от 0 до 100 процентов, которое записывается при минимально...
sadovskaya02
20.12.2022 03:37
Дано двузначное число, введённое с клавиатуры . найти сумму его цифр....
Азим721
27.04.2022 10:15
Перевод числа Переведите из шестнадцатеричной системы счисления в двоичную число EE. В ответе укажите только двоичные цифры, основание системы счисления указывать не надо....
Дильназ231
09.05.2023 09:31
Применяя правило счета, запишите продвижение пяти целых чисел, следующих за указанным. 10 в двоичной 101 в троичной 20 в троичной 15 в шестиричной 11 в пятиричной 11 в шестиричной...
59494920948583
03.08.2021 11:09
Выполнить табулирования и построить график в ЭКСЕЛЬ. Y1=l^x, Y2=x^(1/3), формала для вычисления Y=l^x-x^(1/3), интервал (0; 3), шаг 0,3. ...
Vip6longin
21.04.2021 10:27
Что понимается под информационными технологиями...
krohaela
16.11.2022 01:05
ИНФОРМАТИКА ПРАВИЛЬНЫЙ ОТВЕТ СДЕЛАЮ ЛУЧШЕ ОТВЕТ...
GgWp2213
13.05.2020 03:25
В режиме «» датчик может определить цвет поднесенного к нему предмета. В режиме «» датчик направляет световой луч на близкорасположенный предмет и по отраженному пучку определяет...
Ответ:
nanakochieva72
12.02.2023 06:44
Проверка существования треугольников не выполняется.
1)
var
x1,y1,x2,y2,x3,y3,x4,y4:real;
sq1,sq2,sq3,sq4,max:real;
procedure s(a1,b1,a2,b2,a3,b3:real;var sq:real);
var s1,s2,s3,p:real;
begin
s1:=sqrt((a2-a1)*(a2-a1)+(b2-b1)*(b2-b1));
s2:=sqrt((a3-a1)*(a3-a1)+(b3-b1)*(b3-b1));
s3:=sqrt((a3-a2)*(a3-a2)+(b3-b2)*(b3-b2));
p:=(s1+s2+s3)/2;
sq:=sqrt(p*(p-s1)*(p-s2)*(p-s3));
end;
begin
write('x1,y1: '); readln(x1,y1);
write('x2,y2: '); readln(x2,y2);
write('x3,y3: '); readln(x3,y3);
write('x4,y4: '); readln(x4,y4);
s(x1,y1,x2,y2,x3,y3,sq1);
s(x1,y1,x3,y3,x4,y4,sq2);
s(x1,y1,x2,y2,x4,y4,sq3);
s(x2,y2,x3,y3,x4,y4,sq4);
writeln('sq1 = ',sq1:5:2,' sq2 = ',sq2:5:2,' sq3 = ',sq3:5:2,' sq4 = ',sq4:5:2);
if sq1>sq2 then max:=sq1 else max:=sq2;
if sq3>max then max:=sq3;
if sq4>max then max:=sq4;
writeln('max = ',max:5:2);
end.
2)
var
x1,y1,x2,y2,x3,y3,x4,y4:real;
sq1,sq2,sq3,sq4,max:real;
function s(a1,b1,a2,b2,a3,b3:real):real;
var s1,s2,s3,p:real;
begin
s1:=sqrt((a2-a1)*(a2-a1)+(b2-b1)*(b2-b1));
s2:=sqrt((a3-a1)*(a3-a1)+(b3-b1)*(b3-b1));
s3:=sqrt((a3-a2)*(a3-a2)+(b3-b2)*(b3-b2));
p:=(s1+s2+s3)/2;
s:=sqrt(p*(p-s1)*(p-s2)*(p-s3));
end;
begin
write('x1,y1: '); readln(x1,y1);
write('x2,y2: '); readln(x2,y2);
write('x3,y3: '); readln(x3,y3);
write('x4,y4: ');
readln(x4,y4);
sq1:=s(x1,y1,x2,y2,x3,y3);
sq2:=s(x1,y1,x3,y3,x4,y4);
sq3:=s(x1,y1,x2,y2,x4,y4);
sq4:=s(x2,y2,x3,y3,x4,y4);
writeln('sq1 = ',sq1:5:2,' sq2 = ',sq2:5:2,' sq3 = ',sq3:5:2,' sq4 = ',sq4:5:2);
if sq1>sq2 then max:=sq1 else max:=sq2;
if sq3>max then max:=sq3;
if sq4>max then max:=sq4;
writeln('max = ',max:5:2);
end.
Пример:
x1,y1: -5 1
x2,y2: -3 4
x3,y3: -1 2
x4,y4: -1 0
sq1 = 5.00 sq2 = 4.00 sq3 = 7.00 sq4 = 2.00
max = 7
0,0
(0 оценок)
Ответ:
Vhrgrg
26.01.2023 01:15
#include <iostream>
using namespace std;
int main() {
cout << "Введите два числа: ";
double n1,n2;
cin >> n1 >> n2;
cout << "Введите знак операции: ";
char op;
cin >> op;
switch(op) {
case '+':
cout << n1+n2 << endl;
break;
case '-':
cout << n1-n2 << endl;
break;
case '*':
cout << n1*n2 << endl;
break;
case '/':
cout << n1/n2 << endl;
break;
default:
cout << "wrong operation" << endl;
break; }
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота