Dimas1694
29.08.2022 16:30

Напишите программу на языке программирования (или составьте алгоритм). подсчитать количество простых чисел в одномерном массиве размером n, состоящем из целых чисел, полученных случайным образом.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
marmeoladikp07wow
14.08.2020 18:17
//
Program n1;
function pr(a:longint):boolean;
var i:longint;
begin
if a<2 then pr:=false
else
begin
pr:=true;
for i:=2 to round(sqrt(a)) do
if a mod i=0 then pr:=false;
end;
end;
const n=15;
var a:array[1..n] of integer;
i,k:integer;
begin
randomize;
k:=0;
for i:=1 to n do a[i]:=random(100);
writeln('массив: ');
for i:=1 to n do write(a[i],' ');
writeln;
for i:=1 to n do
if pr(a[i]) then k:=k+1;
writeln('кол-во простых чисел: ',k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота