Anopsis
10.09.2021 16:44

PYTHON 3 На вход программе подается натуральное число nn, а затем nn различных натуральных чисел, каждое на отдельной строке. Напишите программу, которая выводит наибольшее и второе наибольшее число последовательности.

Формат входных данных

На вход программе подаются натуральное число n 2n≥2, а затем nn различных натуральных чисел, каждое на отдельной строке.

Формат выходных данных

Программа должна вывести два наибольших числа, каждое на отдельной строке.

Sample Input 1:

5

1

2

3

4

5

Sample Output 1:

5

4

Sample Input 2:

8

9

7

5

4

3

2

78

1

Sample Output 2:

78

9

Sample Input 3:

13

1

2

3

5

8

233

13

21

34

377

55

89

144

Sample Output 3:

377

233

===

вот мой код

largest = -1

num = int(input())

for i in range(0,num):

num = int(input())

if num > largest:

largest = num

print(largest)

=

это отступы

максимальное я нашел а то что перед максимальным у меня не получается

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
boosoosv
04.02.2021 18:40

mins = 9*99

maxs = -9*999

count = int(input())

if count < 2:

   print("Не может быть меньше двух")

else:

   for i in range(count):

       a = int(input())

       if a < mins:

           mins = a

       elif a > maxs:

           maxs = a

if count > 2:

   print(maxs)

   print(mins)

   

# такой же, но более памятозатратный.

# можно конечно оптимизировать, но для учебного варианта пойдёт

a = []

count = int(input())

if count < 2:

   print("Не может быть меньше двух")

else:

   for i in range(count):

       d = int(input())

       a.append(d)

if count > 2:

   print(max(a))

   print(min(a))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота