IIIayni
13.02.2020 19:53

. Напишите программу, которая с цикла for выводит любую строчку из стихотворения или песни 7 раз.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mehili
15.11.2021 08:03

import java.util.Scanner;

import java.util.ArrayList;

public class multi {

   public static void main(String[] args) {

       int counter = 0;

       ArrayList<Integer> arr = new ArrayList<>();

       Scanner scanner = new Scanner(System.in);

       for (int i = 1; i<=6; i++) {

           while (true) {

               System.out.print("Введите " + i + "-е значение: ");

               int v = Integer.parseInt(scanner.nextLine());

               

               if (v == 0) counter++;

               else counter = 0;

               if (i == 6 && counter >= 6) {

                   System.out.println("Все значения не могут быть равны 0!");

                   continue;

               }

               

               arr.add(v);

               break;

           }

       }

       System.out.println(arr);

       System.out.println(multiply(arr));

   }

   public static Integer multiply(ArrayList<Integer> arr) {

       int v = 0;

       for (int i : arr) {

           if (i != 0) {

               if (v == 0) v = i;

               else v *= i;

           }

       }

       return v;

   }

}

0,0(0 оценок)
Ответ:
Vexicy
04.03.2022 02:50
Program z3;
const n=3;
var A:array[1..n] of string;
var B:array[1..n] of string;
i,k:byte;

begin
writeln('Ввод названий газет:');
for i:=1 to n do
 begin write('[',i,'] '); readln(A[i]);end;
writeln('Ввод фамилий подписчиков:');
for i:=1 to n do
 begin write('[',i,'] '); readln(B[i]);end;
k:=0;
for i:=1 to n do
 if (A[i]='Правда') and (B[i]='Петров') then k:=i;
if k<>0 then writeln('Да, Петров выписывает Правду.')
        else writeln('Петров не выписывает Правду.');
end.

Пример:
Ввод названий газет:
[1] Правда
[2] Мир
[3] Атеист
Ввод фамилий подписчиков:
[1] Петров
[2] Дружаев
[3] Базаров
Да, Петров выписывает Правду.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота