элирка3
20.07.2020 08:15

1. Заполните массив кубами случайных целых чисел в интервале (1,5). Перемножьте все элементы списка с четными индексами (то есть A[0], A[2], A[4], ...). Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

2. Заполните массив из 10 элементов. Выведите на экран произведение четных элементов.
Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.
Выходные данные
Выведите ответ на задачу.

ответом на задачи является программа на языке python.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rustiuh
01.02.2022 07:51

Программа:

Python:

№1)

A = list(input().split())

pr = 1

for i in range(len(A)):

   if i % 2 == 0:

       pr *= int(A[i])

print(f'{A}\n{pr}')

№2)

from random import randint

arr = [randint(-10, 10) for i in range(10)]  # массив из 10 чисел от -10 до 10

pr = 1

for i in arr:

   if i % 2 == 0 and i != 0:  pr *= i

print(f'{arr}\n{pr}')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота