ЯЯЯ1118526
19.04.2021 13:21

Составить программу по коду.
a=4 b=3.5 c=2
print((a+2*b-3*c)/(5*a+b))

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arturdadayan
05.05.2023 03:42
Причины войны были следующие: обострение Восточного вопроса, противоречия из-за черноморских проливов, политика Англии и Франции, направленная на вытеснение России с Балкан. Важную роль в данном событии сыграл адмирал Нахимов. В ноябре 1853 года Нахимов разгромил Турецкий флот в Синопской бухте. Уничтожил береговые укрепления и взял в плен командующего турецкой эскадрой Осман-Пашу. В 1854-1855 годах Нахимов руководил обороной Севастополя. Был командующим Севастопольского порта, занимал пост временного губернатора Севастополя. Россия потерпела поражение в Крымской войне, потеряла устье Дуная и Южную Бессарабию. России запрещалось иметь военный флот в Чёрном море и укрепления на его берегах. Другим важным событием данного периода стало зарождение военно-полевой хирургии. Причины данного события были следующие: необходимость увеличить качество оказания медицинской солдатам, сократить число людских потерь, одержать победу в войне.
0,0(0 оценок)
Ответ:
danilukm548p09te8
09.12.2020 17:04
Программа распознаёт только целые числа.

Var
   f:file of char;
   C:char;
   k,s:integer;
Begin
Assign(f,'file.txt');
Reset(f);
k:=0;
s:=1;
Write('Найденные числа:');
Repeat
Read(f,C);
if ('0'<=C)and(C<='9') then
   Begin
   k:=k+1;
   Write(' ');
   While ('0'<=C)and(C<='9')and Not Eof(f) do
      Begin
      Write(C);
      Read(f,C);
      if C=#13 then s:=s+1;
      End;
   End;
Until Eof(f);
Close(f);
WriteLn;
WriteLn('Их количество: ',k);
WriteLn('Количество строк в файле: ',s);
End.

Результат работы программы:

Найденные числа: 1 2 3 7 8 9 11 12 3 2 1 8 1 2 3 4
Их количество: 16
Количество строк в файле: 5

Чтобы программа работала данный файл должен находиться в одной папке с программой:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота