Semfore
27.06.2021 10:16

Напишите программу для выполнения перестановки первого нечетного и первого отрицательного элементов массива​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bella77777
03.03.2021 19:51

#Python 3.8.3

from typing import *

def FindFirstIndex(source: Iterable[Any], predicate: Callable[[Any], Any]):

   for index, item in enumerate(source):

       if (predicate(item)):

           return index

def main():

   arr = [1, 2, 3, 4, 5, -1, 2, -4]

   firstOdd = FindFirstIndex(arr, lambda p: p % 2 != 0)

   firstNegative = FindFirstIndex(arr, lambda p: p < 0)

   arr[firstOdd], arr[firstNegative] = arr[firstNegative], arr[firstOdd]

   print(arr)

if __name__ == '__main__':

   main()

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота