фреска25
29.08.2021 14:30

Составьте программу закрашивания 4 клеток по диагонали влево вверх от робота считая что изначально робот находится в правом нижнем углу поля​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mariya260464
24.03.2021 06:03

A - Неверно. Сканер - устройство ввода.

B - Верно. Клавиатура - устройство ввода.

C - Верно. Монитор - устройство вывода.

D - Неверно. Микрофон - устройство ввода.

Получаем логические переменные: A = 0, B = 1, C = 1, D = 0.

Подставим их в предложенные уравнения и посмотрим на результат (он должен быть равен истине):

d⇔c⇒¬a∨b∧d = 0⇔1⇒¬0∨1∧0 = 0⇔1⇒1 = 0⇔1 = 0 - нам не подходит

b⇒(a∧¬d)∨(c⇔¬a) = 1⇒(0∧¬0)∨(1⇔¬0) = 1⇒(0∧1)∨(1⇔1) = 1⇒0∨1 = 1⇒1 = 1 - подходит

¬(a∧d)∨(¬b⇔c⇒d) = ¬(0∧0)∨(¬1⇔1⇒0) = ¬0∨(¬1⇔0) = 1∨(0⇔0) = 1∨1 = 1 -  подходит

¬a∨b⇒c⇔¬d∧¬b = ¬0∨1⇒1⇔¬0∧¬1 = 1∨1⇒1⇔1∧0 = 1⇒1⇔0 = 1⇒1⇔0 = 1⇔0 = 0 - не подходит

На скриншоте вами выбраны верные пункты

0,0(0 оценок)
Ответ:
leonidkhadzhinov
24.03.2021 06:03

1) var A: array [1..7,1..9] of integer;

var i,j,k,n:integer;

var Sr: double;

begin

randomize;

writeln ('Массив случайных чисел');

 for i:=1 to 7 do

   begin

     for j:=1 to 9 do begin

     A[i,j]:= random (56) + 25;

     write (A[i,j]:4);

     end;

     writeln;

   end;

   

 for i:=1 to 7 do

  begin

   for j:=1 to 9 do

     begin

     If A[i,j] mod 2 = 0 then

     begin

     Sr:= Sr + A[i,j];

     k:= k + 1;

     end

     else n:= n + 1;

     end;

  end;  

  Sr:= Sr / k;

  Writeln ('Среднее арифмитическое четных элементов: ', Sr);

  Writeln ('Количество нечетных элементов: ', n);

end.

2)const n = 5;

const b = 5;

var A: array [1..n,1..b] of integer;

var i,j:integer;

begin

writeln ('Введите массив');

 for i:=1 to n do

   begin

     for j:=1 to b do begin

     Read (A[i,j]);

     end;

     end;

     

   

  for i:=1 to n do

   begin

     for j:=1 to b do begin

     If A[i,j] < 0 then

     

     A[i,j]:= 1;

     write (A [i,j]:4);

     

     end;

     Writeln;

   end;

   

 

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота