andendlife
03.03.2023 11:32

Паскаль, процедуры и функции
Составить программу, определяющую, в каком из данных двух чисел больше цифр (создать подпрограмму для вычисления кол-ва цифр в числе).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hfhfhfhffhhfdkdd
27.08.2020 22:17

===== PascalABC.NET =====

function КолЦифр(n: integer): integer;

begin

 (n, Result) := (Abs(n), 0);

 while n > 0 do

 begin

   Inc(Result);

   n := n div 10

 end

end;

begin

 var (a, b) := ReadInteger2('Введите два целых числа:');

 case Sign(КолЦифр(a) - КолЦифр(b)) of

   1: Print('В первом числе больше цифр');

   0: Print('В числах одинаковое количество цифр');

 else

   Print('Во втором числе больше цифр')

 end

end.


Паскаль, процедуры и функции Составить программу, определяющую, в каком из данных двух чисел больше
0,0(0 оценок)
Ответ:
olesya3010ozvprt
27.08.2020 22:17

var x1,x2:integer;

function f(x:Integer):Integer ;

var

k:integer;

begin

while x>0 do

begin

x:=x div 10;

k:=k+1;

end;

f:=k;

end;

begin

read(x1,x2);

if f(x1)>f(x2) then

write('В первом числе больше цифр')

else if

f(x2)>f(x1) then

write('В втором числе больше цифр')

else

write('В числах одинаковое количество цифр')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота