zahcar629
25.12.2022 04:56

недавно начал изучать python, решил написать программу, которая будет показывать текущую погоду. ошибка: Traceback (most recent call last):
line 41, in
rain_dict = mgr.weather_at_place("place").observation.rain
AttributeError: 'Observation' object has no attribute 'observation'. смотрел по документации - всё вроде правильно. версия модуля и python последняя. ошибок не нашёл. вот сам код:

from pyowm import OWM

from pyowm.utils.config import get_default_config

from pyowm.utils import config

from pyowm.utils import timestamps

from colorama import init

from colorama import Fore, Back, Style

init()

print(Fore.BLACK)

print(Back.CYAN)

place = input("(Введите город):")

config_dict = get_default_config()

config_dict['language'] = 'ru'

owm = OWM("a4cd51048d5f98eb0a91b299959a86dc", config_dict)

mgr = owm.weather_manager()

observation = mgr.weather_at_place("place")

weather = observation.weather

wind_dict_in_meters_per_sec = observation.weather.wind()

temp_dict_celsius = weather.temperature("celsius")

temp_dict_kelvin = weather.temperature()

temp_dict_fahrenheit = weather.temperature("fahrenheit")

rain_dict = mgr.weather_at_place("place").observation.rain

print(Back.MAGENTA)

print("Температура сейчас около: " + str(temp_dict_celsius["temp"]) + " C ")

print("Температура в Фаренгейтах: " + str(temp_dict_fahrenheit["temp"]) + " F ")

print("Температура в Кельвинах: " + str(temp_dict_kelvin["temp"]) + " K ")

print("Скорость ветра: " +str(wind_dict_in_meters_per_sec["speed"]) + " м/c ")

print("Выпавшие осадки за последний час: " + str(rain_dict["1h"]))

print("Выпавшие осадки за последние 3 часа: " + str(rain_dict["3h"]))

print("В городе " + place + " сейчас " + weather.detailed_status)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lirazelio
01.06.2023 03:45

#include <iostream>

#include <math.h>

#define _USE_MATH_DEFINES

int main(){

 double a,b,c = 1;

 std::cout << "A:"<< std::endl;

 std::cin >> a ;

 std::cout << "B:"<< std::endl;

 std::cin >> b;

 std::cout << "C:"<< std::endl;

 std::cin >> c;

 double x = 2 * std::log(a) - 1 / b / c + std::tan(M_PI * b * c);

 double y = std::cos(0.387 * a) + std::sqrt(std::abs(a + b));

 std::cout << "x = " << x << "\n" << "y = "<< y << std::endl;

 std::cin >> a;

 return 0;

}

Компилятор MinGW

0,0(0 оценок)
Ответ:
anastasiabobilevich
22.10.2022 22:09
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите текст, завершив его точкой:'+NewLine);
  s:=s[:Pos('.',s)];
  var k:=s.ToWords.Select(w->w.MatchValues('\b[A-ZА-ЯЁ][a-zа-яё]*\b'))
    .Where(w->w.Count>0).Count;
  Writeln('Найдено слов: ',k)
end.

Пример
Введите текст, завершив его точкой:
Карл у Клары украл кораллы Клара у Карла украла кларнет.
Найдено слов: 4

Примечание: Буквы латинского алфавита также обрабатываются.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота