Baka1111
16.10.2020 23:12

Составить программу, используя одномерные массивы: Дан массив А (15). Сформировать новый
массив из отрицательных чисел исходного массива.​
(Pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Radmula
27.02.2021 01:27

var

 a, b: array[1..15] of integer;

 i, k: integer;

begin

 randomize;

 k := 1;

 WriteLn('Массив:');

 for i := 1 to 15 do

 begin

   a[i] := random(200) - 100;

   Write(a[i], ', ');

   if a[i] < 0 then

   begin

     b[k] := a[i];

     inc(k);

   end;

 end;

 WriteLn;

 WriteLn('Новый массив:');

 for i := 1 to k - 1 do Write(b[i], ', ');

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота