Anleki
18.07.2022 02:56

Написать программу нахождения минимального из 4 чисел используя процедуру нахождения наименьшего из двух чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
26.01.2021 23:20

У вас там преподаватели вообще не запариваются с написанием домашки? Второй раз за день одно задание.

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

 if a<b then min:=a else min:=b;

end;

begin

 writeln('Введите 4 числа ');

 readln(x,y,z,n);

 Minim(x,y,min1);

 Minim(z,n,min2);

 Minim(min1,min2,x); //x нам уже не нужен. А чем объявлять еще одну переменную, давай использовать ненужную

 writeln('Минимальное число из четырех =',x);

end.

0,0(0 оценок)
Ответ:
6г56г
26.01.2021 23:20

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

if a<b then min:=a else min:=b;

end;

begin

writeln('Введите 4 числа ');

readln(x,y,z,n);

Minim(x,y,min1);

Minim(z,n,min2);

Minim(min1,min2,x);

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота