daniilfd
15.07.2021 17:27

Найдите минимальный по модулю элемент массива.
C++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dashadgankozde8z
31.01.2021 20:41
Var a1,a2,a3,a4,a5,max: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1>a2) then max:= a1else max:=a2;
if (a2>a3) then max:=a2else max:=a3;
if (a3>a4) then max:=a3else max:=a4;
if (a4>a5) then max:=a4else max:=a5; 
  end;
writeln (max);
end. 
Аналогично с минимальным числом.
var a1,a2,a3,a4,a5,min: integer;
begin
writeln ('Введите 5 чисел через пробел: ');
readln (a1,a2,a3,a4,a5); 
  begin
if (a1<a2) then min:= a1else min:=a2;
if (a2<a3) then min:=a2else min:=a3;
if (a3<a4) then min:=a3else min:=a4;
if (a4<a5) then min:=a4else min:=a5; 
  end;
writeln (min);
end.  
Можно так же решить с массива, если нужно пишите.
0,0(0 оценок)
Ответ:
Ирина1895031
21.09.2020 13:21
Для решения определим 
1. Время передачи по высокоскоростному каналу
2. Время передачи по низкоскоростному каналу
3. Время для получения первых 1024 Кб
4. Всё сложим.

2^20 бит/с = 2^20 / 8 / 1024 Кбайт/с = 2^20 / 2^3 / 2^10 = 2^7 Кбайт/с
2^13 бит/с = 2^13 / 8 / 1024 Кбайт/с = 2^13 / 2^3 / 2^10 = 2^0 = 1 Кбайт/с
10 Мб равно 10*1024 Кбайт = 10*2^10 Кбайт.

По высокоскоростному каналу файл будет передаваться
(10*2^10) / 2^7 = 10*2^3 = 80 секунд

По низкоскоростному каналу файл будет передаваться
(10*2^10) / 1 = 10*2^10 = 10240 секунд.

Первые 1024 Кбайт будут передаваться
2^10 / 2^7 = 8 секунд

Общее время 80+10240+8 = 10328 секунд.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота