яна1767
12.04.2022 23:25

составить программу для нахождения Y в паскаль ​


составить программу для нахождения Y в паскаль ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
степан169
19.08.2021 05:03
Салат оливье. ингредиенты 1 баночка зеленого горошка (400г) 300 г мяса 4 яйца 350 г картофеля 100 г соленых или маринованных огурцов 150 г лука соль майонез алгоритм приготовления: 1.мясо отварить до готовности (варить около 40 минут после закипания) . 2.остудить. 3.лук мелко покрошить. 4.залить его кипятком и оставить на 10 минут, затем воду слить, лук промыть в холодной воде. 5.мясо нарезать кубиками. 6.картофель почистить, нарезать кубиками. 7. яйца мелко покрошить. 8.огурцы мелко нарезать. 9.смешать картофель, мясо, лук, горошек (воду слить) , яйца, огурцы. 10.посолить. 11. заправить майонезом. 12. украсить по вкусу, например зеленым горошком
0,0(0 оценок)
Ответ:
TonyaOgneva
11.07.2022 11:08
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10

// PascalABC.NET 3.0,сборка 1076
begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходная последовательность');
  a.Println;
  Writeln('Сумма элементов: ',a.Sum);
  Write('Кол-во четных, кратных пяти: ');
  Writeln(a.Where(x-> x mod 10 = 0).Count)
end.

Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота