2499930
18.01.2021 13:36

Написать программу на языке с++(желательно в компиляторе shell c++)

напишите программу, которая сортирует массив и находит количество различных чисел в нем.
программа 8-9 класса

решите, надо!
заранее .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yurafenchishin
08.10.2020 16:38

#include <iostream>

using namespace std;

int main() {

int n, a=1;

cin>>n; //Кол-во элементов массива

int arr[n];

for (int i=0; i<n; ++i) cin>>arr[i]; //Ввод массива

for (int i=0; i<n-1; i++) { //Сортировка по возрастанию

 for (int j=0; j<n-i-1; j++) {

  if (arr[j]>arr[j+1]) {

                int temp=arr[j];

                arr[j]=arr[j+1];

                arr[j+1]=temp;

        }

    }

}

for (int i=0; i<n; ++i) cout<<arr[i]<<" "; //Вывод массива

cout<<endl;

if (n==1) cout<<a;

else {

 for (int i=1; i<n; ++i) {

  if (arr[i]>arr[i-1]) ++a;

 }

 cout<<a; //Вывод кол-ва различных значений элементов массива

}

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота