Flif
29.10.2022 14:31

составить программу табуляции функции на отрезке 1,6 с шагом 0,2

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Илья11345
10.11.2021 18:11
ответ:

При любых A, B и C данное выражение истинно.

Объяснение:

Для начала упростим эквивалентность и импликацию.

Экивалентность (≡) раскрывается вот так:

x ≡ y = x ∧ y ∨ -x ∧ -y

Применим к нашим данным:

A ∧ B ≡ B ∧ C = (A ∧ B ∧ B ∧ C) ∨ ( -(A ∧ B) ∧ -(B ∧ C) ) =

Первая скобка упрощается по закону повторения (B ∧ B = B), а вторая скобка, а точнее отрицание раскрывается по закону де Моргана:

= (A ∧ B ∧ C) ∨ ( -A ∨ -B ∧ -B ∨ -C) =

По закону исключения третьего (A ∨ -A = 1) упрощаем запись:

= 1

На самом деле я здесь очень сильно упростил запись. На самом деле нам не помешало бы раскрыть данную дизъюнкцию, "перемножив" A на -A, A на -B, A на -C, B на -A и так далее. Но в итоге данная запись сократится в единицу.

Теперь рассмотрим импликацию (⇒):

(x ⇒ y) = -x ∧ y

Применим к нашим данным:

(-C ⇒ A) = -(-C) ∧ A =

По закону двойного отрицания (-(-C) = C):

C ∧ A

Итого наш пример принял такой вид:

1 ∨ C ∧ A

Данное выражение всегда истинно, поскольку дизъюнкция истинна в том случае, когда одно из выражений истинно, а в нашем случае левая часть (единица), то есть дизъюнкция вседа истинна.

0,0(0 оценок)
Ответ:
Doctor216
30.06.2021 01:27

static void Main(string[] args)

       {

           Console.WriteLine("Введіть напрям руху");

           char S = Console.ReadKey().KeyChar;

           S = Char.ToUpper(S);

           Console.WriteLine();

           Console.WriteLine("Введіть цифрову команду ");

           Console.WriteLine();

           

           String temp = Console.ReadLine();

           int N  = Convert.ToInt16(temp);

           Console.WriteLine();

           switch (S)

           {

               case 'П': Console.WriteLine("Робот Рухається на Північ");

                   break;

               case 'З':

                   Console.WriteLine("Робот Рухається на Захід");

                   break;

               case 'С': Console.WriteLine("Робот Рухається на Схід");

                   break;

               case 'Д': Console.WriteLine("Робот Рухається на Південь");

                   break;

               default:

                   Console.WriteLine("Помилка вводу напряму руху!");

                   break;

           }

           switch (N)

           {

               case 0:

                   Console.WriteLine("Робот Продовжив рух ");

                   break;

               case 1:

                   Console.WriteLine("Робот Повернув на ліво");

                   break;

               case -1 : Console.WriteLine("Робот Повернув на право");

                   break;

               

               default:

                   Console.WriteLine("Помилка вводу напряму руху!");

                   break;

           }

           Console.ReadKey();

       }

       

Объяснение:

Если я правильно понял условие :) могут возникнуть проблемы в с отображением украинской буквы і

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота