nikoleller
28.08.2021 20:38

C++ Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру.

Примеры
входные данные
5
выходные данные
101

входные данные
-14
выходные данные
-1110

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pva1992
09.02.2021 16:43

Код программы:

#include <iostream>

#include <locale>

#include <time.h>

using namespace std;

int bit(int a) {

int sum = 0, p = 1;

while (a) {

 sum += p * (a % 2);

 p *= 10;

 a /= 2;

}

return sum;

}

int main()

{

setlocale(LC_ALL, "Russian");

int a;

cout << "Введите число: ";

cin >> a;

cout<<"Число в 2-ой системе счисления: "<<bit(a)<<endl;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота