kopnina
26.03.2021 10:52

Написать программу на языке VBA. Исходные данные вводить в ходе выполнения программы. Использовать конструкцию циклического алгоритма.
Условие задачи: Задан массив А(5, 5). Найти номер строки и номер столбца с
минимальным значением.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hshgahahah
31.12.2021 21:13

1) Функциональные клавиши F1-F12 предназначены для выполнения ряда команд при работе с некоторыми программами.

2) Символьные (алфавитно-цифровые) клавиши используются для ввода информации в компьютер.

3) Клавиши управления курсором перемещают курсор в начало строки, в конец строки, на страницу вверх и на страницу вниз.  

4) Дополнительные клавиши, расположенные с правой стороны клавиатуры, могут работать в двух режимах, переключаемых клавишей NumLock:

- при включённом индикаторе NumLock это удобная клавишная панель с цифрами и знаками арифметических операций, расположенными, как на калькуляторе;

- если индикатор NumLock выключен, то работает режим управления курсором.

5) Специальные клавиши (Enter, Esc, Shift, Delete, Backspace, Insert и др.) — это клавиши для специальных действий;

   Клавиша Enter завершает ввод команды и вызывает её выполнение. При наборе текста служит для завершения ввода абзаца.

   Клавиша Esc, расположенная в левом верхнем углу клавиатуры, обычно служит для отказа от только что выполненного действия.

Объяснение:

0,0(0 оценок)
Ответ:
Animashka11
27.05.2022 11:05
Задача с регионального этапа года)
На паскале решение выглядит так:
var
s,a1,a2,a3,a4:int64;
i,o:text;

function min(x,y:int64):int64;
begin
  if x>y then
   min:=y else
    min:=x;
end;

begin
assign(i,'pobeda.in');
reset(i);
read(i,a1,a2,a3,a4);
close(i);
s:=min(a1,a2)+min(a3,a4);
assign(o,'pobeda.out');
rewrite(o);
writeln(o,trunc(sqrt(s)));
close(o);
end.

Если ты пишешь на другом языке программирования, то могу коротко рассказать суть решения. Большой квадрат со стороной x получается из x^2 маленьких квадратом, которые состоят из двух прямоугольных треугольников. Такие квадраты можно составить из треугольников a1 и a2 или a3 и a4. Поэтому берём минимальное значение из a1 и a2 и минимальное из a3 и a4. Суммируем эти значения, берём корень и округляем в меньшую степень. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота