Seks7383
27.09.2021 18:08

Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программирования Pascal)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Yuliya475
25.01.2021 13:48

см. объяснения + скрин

Объяснение:

program prog;

var

  num,chetnoe,nechetnoe,ost :integer;

begin

writeln('Vvedite chislo:');

readln(num);

chetnoe:=0;

nechetnoe:=0;

if num=0 then chetnoe:=1 else

begin

 while (num<>0) do begin

  ost:=(num mod 10) mod 2;

  if (ost=0) then chetnoe:=chetnoe+1

  else nechetnoe:=nechetnoe+1;

  num:=num div 10;

 end;

end;

writeln('четныx = ',chetnoe);

writeln('нечетных = ',nechetnoe);

end.


Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программиров
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота