msvittenberg
01.07.2021 02:19

Написать программу, в которой переменной _y_ присваивается значение наибольшего из трех велечин a, b, c. Указать все исходные данные, конструкции, которые будете использовать. А затем только программа.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vladykasevera
12.10.2022 11:10
Не вижу и малейшего отношения к программированию.
Что именно вы хотите видеть в программном коде ? 

ответ:
Алеша, Боря, Витя. 
Алеша с кем-то идет к троллейбусу, когда подходит с ним к остановке появляется третий друг, который кричит из окна Боре (Значит Алена шел с Борей к троллейбусу). Исходя из этого Витя ездит на автобусе. Боря на троллейбусе (ибо он проводил друга до остановки, значит сам не поехал на троллейбусе, т.к. тогда было бы "вместе" шли или подобное), а значит троллейбус ему не нужен, а нужен трамвай.

ответ:
Витя - автобус
Боря троллейбус
Алеша - трамвай. 

Все. Что тут еще программировать, а ? это задача только на логику, а не на программирование.. 
0,0(0 оценок)
Ответ:
мама1021
09.12.2022 22:26
Задача 1.
const
  n=30;
var
  a,b:array[1..n] of integer;
  i,j,k:integer;
begin
  { самое сложное - создать такой массив,
    где положительные и отрицательные элементы будут случайно
    перемешаны и их будет по n/2.
    Если организовать ввод с клавиатуры, то это гораздо проще.
  }
  Randomize;
  { инициализация "флажком" - значением 1000 }
  for i:=1 to n do a[i]:=1000;
  { сначала генерируем n/2 случайных отрицательных на случайных местах }
  for i:=1 to (n div 2) do
  begin
    k:=Random(50)-50; { случайное отрицательное значение }
    { а теперь ищем случайное свободное место }
    repeat
      j:=Random(30)+1
    until a[j]=1000;
    a[j]:=k
  end;
  { теперь осталось сгенерировать n/2 случайных положительных чисел
    и разместить их на свободных местах }
  for i:=1 to (n div 2) do
  begin
    k:=Random(50)+1; { случайное положительное значение }
    { а теперь ищем свободное место }
    j:=0;
    repeat
      Inc(j)
    until a[j]=1000;
    a[j]:=k
  end;
  { и только отсюда начинается собственно задание }
  Writeln('Исходный массив');
  for i:=1 to n do Write(a[i]:4);
  Writeln;
  { j - количество обработанных отрицательных,
    k - количество положительных,
    а массив строим так, что отрицательные элементы на нечетных местах }
  if a[1]<0 then begin b[1]:=a[1]; j:=1; k:=0 end
  else begin b[2]:=a[1]; j:=0; k:=1 end;
  for i:=2 to n do
    if a[i]<0 then
    begin Inc(j); b[2*j-1]:=a[i] end
    else begin Inc(k); b[2*k]:=a[i] end;
  Writeln('Результирующий массив');
  for i:=1 to n do Write(b[i]:4);
  Writeln
end.

Тестовое решение:
Исходный массив
  43  44  34  21  14 -26  32  35 -25  -8  42 -35 -37  12  45 -25  31   8 -16  -5   8 -25 -19 -15 -27 -16  12  26 -14 -41
Результирующий массив
 -26  43 -25  44  -8  34 -35  21 -37  14 -25  32 -16  35  -5  42 -25  12 -19  45 -15  31 -27   8 -16   8 -14  12 -41  26
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота