микс111111
06.09.2021 22:14

Напишите программу, используя процедуру в которой: 1) строка проверяется на палиндром ( выводится соответствующее сообщение "да" или "нет") 2) выводит количество символов "k" и "n" в строке. Пипец как

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gr1mez
25.06.2022 02:30

1. Среднее арифметическое.

#include "stdafx.h"

#include <iostream>

using namespace std;

int main()

{

int  num; float arithm = 0, count = 0, sum = 0;

cout << "Enter numbers (0 - a sign of the end of input) :  " << endl;

do

{

 cin >> num;

 if (num != 0)

 {

  count++;

  sum += num;

 }

} while (num != 0);

arithm = sum / count;

if (sum == 0) cout << "Error." << endl; else  

cout << "The arithmetic mean of these numbers = " << arithm << endl;

system ("pause");

return 0;

}

2. Максимальный элемент последовательности.

#include "stdafx.h"

#include <iostream>

using namespace std;

int main()

{

int  num; float max = INT_MIN, count = 0, sum = 0;

cout << "Enter numbers (0 - a sign of the end of input) :  " << endl;

do

{

 cin >> num;

 if (num != 0)

 {

  if (num > max) max = num;

 }

} while (num != 0);

if (max == INT_MIN) cout << "Error." << endl; else

cout << "Maximum element: = " << max << endl;

system ("pause");

return 0;

}

0,0(0 оценок)
Ответ:
armodno
25.06.2022 02:30

import java.util.Scanner;

class Main {

   // getter функция, берущая значение у пользователя

   static int getNumb() {

       Scanner numbS = new Scanner(System.in);

       int numb = numbS.nextInt();

       return numb;

   }

   public static void main(String [ ] args) {

      // Инициализация нужных переменных

       int numbs[] = new int[99];

       int i = 0;

       int max = 0;

      // До тех пор, пока не будет введён 0, будет вызываться функция getNumb

       while(true) {

           numbs[i] = getNumb();

           if(numbs[i] == 0) {

               break;

           }

          // Если введённый элемент массива больше переменной max, то ей присваивается этот элемент

           else if(numbs[i] > max) {

               max = numbs[i];

           }

       }

       System.out.print(max);

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота