dashalarkina131
20.03.2023 16:09

Записать на языке программирования и составить блок-схему для следующих задач:1. Даны катеты прямоугольного треугольник. Найти гипотенузу.2. Даны x, y, z. Написать программу для вычисления b:b= (корень из x + 4) разделить на (модуль y - 2)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Абдусатор
28.03.2022 00:30
калькулятор сам составлял

#include<iostream>

 

using namespace std;

 

int main()

{

   setlocale( LC_ALL, "Russian" );

       float a,b,s;

       int dp;

       

   cout << "Привет! Я калькулятор!Какие действие вы будете выполнять:" << endl;

       cout << "1. Сложение. " << endl;

       cout << "2. Отнимание." << endl;

       cout << "3. Умножение." << endl;  

       cout << "4. Деление." << endl;

 

       cout << "Введите число для выбора действия" << endl;

 

       cin >> dp;

 

       switch(dp)

       {

       case 1:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a + b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

   break;

 

case 2:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a - b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

 

case 3:

               cout << "Число a = " << endl;

       cin >> a;

       cout << "Число b = " << endl;

       cin >> b;

               s = a * b;

               cout << "\n" << a << " * " << b << " = "<< s << endl;

               break;

 

               case 4:

               cout << "Число a =  "  << endl;  

               cin >> a;

               cout << "Число b =  " << endl;

       cin >> b;

               s = a / b;

               cout << "\n" << a << " / " << b << " = "<< s << endl;

               break;

       }

       

 

return 0;

}

1

0,0(0 оценок)
Ответ:
Anya2k17
07.07.2020 02:01

1. можно выделить лишь три основных вида алгоритмов (для краткости далее будем называть их линейные, разветвляющиеся и циклические алгоритмы):

• линейной структуры,

• разветвляющейся структуры,

• циклической структуры.

Линейный алгоритм – алгоритм, в котором порядок действий фиксирован и каждое действие выполняется только один раз.

Разветвляющаяся структура алгоритм, при выполнении которого каждый раз последовательность действий может быть разная. Схема подобного алгоритма обязательно содержит хотя бы один блок (символ) "решение", который и обеспечивает разветвление вычислительного процесса.

Алгоритм циклической структуры – это алгоритм, в котором предусмотрено неоднократное выполнение одной и той же последовательности действий. На практике часто встречаются задачи, в которых одно или несколько действий бывает необходимо повторить несколько раз.

2. Блок-схема — рас тип схем (графических моделей), описывающих алгоритмы или процессы, в которых отдельные шаги изображаются в виде блоков различной формы, соединенных между собой линиями, указывающими направление последовательности.

3. Псевдоко́д — компактный, зачастую неформальный язык описания алгоритмов, использующий ключевые слова императивных языков программирования, но опускающий несущественные для понимания алгоритма подробности и специфический синтаксис.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота