tatianani
21.07.2020 01:57

Написать программу: при вводе числа в двоичной системе нужно посчитать количество нолей и единиц а при вводе числа больше 1 будет выдавать error​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fegancev
13.06.2020 15:40

На Python:

number = input('Введите число в двоичной системе счисления: ')

number_of_zeros = 0

number_of_units = 0

for i in number:

   if i == '0':

       number_of_zeros += 1

   elif i == '1':

       number_of_units += 1

try:

#    print('Введеное число: ' + str(int(number, 2)))

   print('Нулей: ' + str(number_of_zeros))

   print('Единиц: ' + str(number_of_units))

except ValueError:

   print('Error')

Объяснение:

закомментировал строку вывода числа в десятичной системе, если понадобится, можно раскомментировать (убрать #), если совсем не надо, можно удалить.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота