Tomokl
16.08.2021 14:13

Задан массив натуральных чисел из 10 элементов: [1,8,6,0,10,2,4,1,1,10]. написать программу, выполняющую последоательно следующие действия: 1. введите массив(список) в программу. 2. Распечатать массив на экране (команда принт). 3. Распечатать срез элементов с 1 по 8 элемент включительно. 4. вычислить сумму [1] и [8] элементов, используя индексы на данные элементы. результат распечатайте на экран. 5. измените элементы [1] и [8] в массиве на значение суммы, вычесленное в предыдущем задание. 6.распечатайте массив на экране

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
polinasenchenk
17.09.2022 15:22

//Задача 3

#include <iostream>

#include <stdio.h>

using namespace std;

string SubString(string str, int startIndex, int endIndex)

{

   string output = "";

   for (int i = startIndex; i < endIndex; i++)

       output += str[i];

   return output;

}

string ToString(int num)

{

   string output = "";

   char symbol = 0;

   int tmp = num;

   while(num != 0)

   {

       tmp = num % 10;

       num /= 10;

       symbol = (char)(tmp + 48);

       output = symbol + output;

   }

   return output;

}

int IndexOf(string str, char symbol)

{

   int index = -1;

   for (int i = 0; i < str.length(); i++)

   {

       if (str[i] == symbol)

       {

           index = i;

           break;

       }

   }

   return index;

}

bool Contains(string text, char symbol)

{

   for (int i = 0; i < text.length(); i++)

   {

       if (text[i] == symbol)

           return true;

   }

   return false;

}

bool IsRepeat(string values, string num)

{

   string tmp = "";

   while (IndexOf(values, ' ') != -1)

   {

       values = SubString(values, IndexOf(values, ' ') + 1, values.length() + 1);

       tmp = SubString(values, 0, IndexOf(values, ' '));

       if (tmp == num)

           return true;

   }

   return false;

}

int main()

{

   const int arrSize = 10;

   int arr[arrSize] = { 10, 22, 10, 76, 44, 22, 22, 12, 9, 76};

   string values = "";

   bool couples = false;

   for (int i = 0; i < arrSize; i++)

   {

       string str = ToString(arr[i]);

       for (int j = i + 1; j < arrSize; j++)

       {

           if (arr[i] == arr[j] && !IsRepeat(values, ToString(arr[j])))

           {

               str += " " + ToString(arr[j]);

               values += " " + ToString(arr[j]);

           }

       }

       if (Contains(str, ' '))

       {

           couples = true;

           cout << "Couple: " << str << endl;

       }

   }

   if (!couples)

       cout << "Couple not detected!" << endl;

   return 0;

}

--------------------------------------------------------------------------

//Задача 5

#include <iostream>

using namespace std;

string ToLower(string text)

{

   string output = "";

   for (int i = 0; i < text.length(); i++)

       output += tolower(text[i]);

   return output;

}

int main()

{

   string str1 = "";

   string str2 = "";

   cout << "Enter first string: ";

   getline(cin, str1);

   cout << "Enter second string: ";

   getline(cin, str2);

   if (ToLower(str1) == ToLower(str2))

       cout << endl << "Strings are equal" << endl;

   else

       cout << endl << "Strings are not equal" << endl;

   return 0;

}


Написать программу на c++ выделены
0,0(0 оценок)
Ответ:
Ука12345
17.09.2022 15:22
12 задание

#include <iostream>

using namespace std;

int main()

{

   for(double i = 1; i <=25; ++i)

   {

       if(((int)i-1)%5==0)

       {

           cout << endl;

       }

       cout << "Earth - " << i << ", moon - " << i*0.17 << endl;

   }

   cin.get();

}

14 задание

#include <iostream>

using namespace std;

int main()

{

   double num,sum=0;

   for(int i=0; i < 5;++i)

   {

       cout << "Enter number #" << i+1 << " -> ";

       cin >> num;

       sum+=num;

   }

   cout << "Average: " << sum/5 << endl;

   cin.get();

   cin.get();

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота