Anastasiua005
08.12.2022 23:14

Написать программу.Вывести порядковый номер элемента одномерного массива, квадрат которого соответствует введенному числу.(паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
светилек
10.02.2023 16:15
//1a

Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
 x2:=i div 10;
   if (sqr(x1)+sqr(x2)) mod 13=0 then writeln(i);
  end;
end.

//1б
Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
   x2:=i div 10;
   if x1+x2+sqr(x1+x2)=i then writeln(i);
  end;
end.

//2
Var
 i,n,a,k1,k2:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(a);
   if a<1985 then k1:=k1+1;
   if a>1990 then k2:=k2+1;
  end;
 writeln('Родившиеся до 1985:',k1);
 writeln('Родившиеся после 1990:',k2);
end.
0,0(0 оценок)
Ответ:
NarkoBaronTif
10.02.2023 16:15
//1a

Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
 x2:=i div 10;
   if (sqr(x1)+sqr(x2)) mod 13=0 then writeln(i);
  end;
end.

//1б
Var
 i,x1,x2:integer;
begin
 for i:=10 to 99 do
  begin
   x1:=i mod 10;
   x2:=i div 10;
   if x1+x2+sqr(x1+x2)=i then writeln(i);
  end;
end.

//2
Var
 i,n,a,k1,k2:integer;
begin
 readln(n);
 for i:=1 to n do
  begin
   readln(a);
   if a<1985 then k1:=k1+1;
   if a>1990 then k2:=k2+1;
  end;
 writeln('Родившиеся до 1985:',k1);
 writeln('Родившиеся после 1990:',k2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота