exomashka
20.02.2023 21:10

Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.


Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ров

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dimitriy2281
16.01.2021 10:30

Код:

list_of_words = {}

searched_num = 0

arr_count = int(input("Введите количество элементов: "))

if arr_count < 0 or arr_count > 1000:

   exit(print("\nНеверное количество элементов!"))

arr = sorted(input("\nВведите массив через пробел: ").split())

oftn_num = int(input("\nВведите число: "))

if arr_count != len(arr):

   exit(print("\nКоличество элементов не совпадает!"))

for i in arr:

   if i in list_of_words:

       list_of_words[i] += 1

       continue

   list_of_words[i] = 1

for key, val in list_of_words.items():

   if val == oftn_num:

       print(key, end=' ')

       searched_num += 1

if not searched_num:

   print(0)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота