apakovaleria
17.05.2023 16:38

Будьте милосердны Составьте программу, в которой описывается массив из записей Ведомость на заработную плату. В ней содержаться данные: ФИО работника, его оклад в день, количество отработанных дней в месяце, а также заработную плату за месяц, которая должна подсчитываться самой программой. Выведите ведомость на экран.

2) На основе созданного массива записей, подсчитайте всю сумму к выплате заработной платы всех работников этого предприятия.

3) На основе созданного массива выведите фамилию работника с самой низкой заработной платой. Если их несколько, выведите всех.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
justnastya1
29.04.2023 02:19
#include <iostream>
#include <string>
using namespace std;

string arabicToRoman(unsigned &number)
{
const unsigned count = 13;unsigned arabic[count] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1
}, i, j;
string roman[count] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX",
"V", "IV", "I" }, result = "";
for (i = 0; i < count; i++) {
for (j = 0; j < number / arabic[i]; j++) {
result += roman[i];
}
number %= arabic[i];
}
return result;
}

int main()
{
unsigned uin = 0;
cin >> uin;
cout << arabicToRoman(uin);
system("pause");
return 0;
}
0,0(0 оценок)
Ответ:
vabimGogolev
25.02.2020 09:52
Для выбора водящего в детской игре N человек становятся в круг, после чего произносится считалка. На первом слове считалки указывается на первого человека в кругу, на втором слове – на второго человека и т. д. После N-го человека снова идёт первый человек (все люди в кругу пронумерованы числами от 1 до N, круг зацикливается, после человека с номером N идёт человек с номером 1). Всего в считалке M слов. Определите, на какого человека придётся последнее слово считалки. Программа получает на вход два целых положительных числа. Первое число N – количество людей в кругу. Второе число M – количество слов в считалке. Оба числа не превосходят 109 . Программа должна вывести одно целое число от 1 до N – номер человека в кругу на которого придётся последнее слово считалки.

var N,k,f,M: longint;beginwriteln ('ВВЕДИТЕ КОЛ-ВО ЛЮДЕЙ В ИГРЕ: ');read(N);writeln('ВВЕДИТЕ КОЛ-ВО СЛОВ: ');read(M);K:=M div N ;F:=M-K*N;if f=0 then write ('НОМЕР ЧЕЛОВЕКА, НА КОТОРОГО ПРИДЕТСЯ ПОСЛЕДНЕЕ СЛОВО  >>  ',N) elsewrite('НОМЕР ЧЕЛОВЕКА, НА КОТОРОГО ПРИДЕТСЯ ПОСЛЕДНЕЕ СЛОВО  >>  ',F);end.                                                                   
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота